博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
求第N数大问题
阅读量:4934 次
发布时间:2019-06-11

本文共 1062 字,大约阅读时间需要 3 分钟。

问题:

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set consists of a single line containing the data set number, followed by a space, followed by 10 space separated decimal integers whose values are between 1 and 1000 inclusive.
Output
For each data set, generate one line of output with the following values: The data set number as a decimal integer, a space, and the 3rd largest value of the corresponding 10 integers.
Sample Input
4
1 1 2 3 4 5 6 7 8 9 1000
2 338 304 619 95 343 496 489 116 98 127
3 931 240 986 894 826 640 965 833 136 138
4 940 955 364 188 133 254 501 122 768 408
Sample Output
1 8
2 489
3 931
4 768

回答:题意输出10个数,求里面第3大数问题。如"1 2 3 4 5 6 7 8 9 1000"里面数值排第三是8。

#include<cstdio>

#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    for(scanf("%d",&T);T;T--)
    {
        int ca,a[12];
        scanf("%d",&ca);
        for(int i=0;i<10;i++)
            scanf("%d",a+i);
        sort(a,a+10);
        printf("%d %d\n",ca,a[7]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/benchao/p/4523773.html

你可能感兴趣的文章
js 中对象的特性
查看>>
hdoj3714【三分】
查看>>
嵌入式开发入门(4)—驱动入门之时序图分析【20121211修改,未完】
查看>>
Python 使用字符串
查看>>
Quartz Core之CALayer
查看>>
java:一个项目的开发过程(转)
查看>>
express框架学习笔记
查看>>
记录一个css的综合运用
查看>>
cygwin daemon
查看>>
瀑布流
查看>>
前端规范
查看>>
Linux与Windows API对比
查看>>
CrossOriginFilter
查看>>
Nginx 反向代理的正确配置
查看>>
Linux日志系统
查看>>
1111 Online Map (30 分)
查看>>
操作系统开发系列—12.f.在内核中添加中断处理 ●
查看>>
excel模板导出一个新的文件
查看>>
PHP教程
查看>>
图解vue生命周期
查看>>